Incident: Issues with Time Recording and Syncing on Remote Payroll (Droid Devices)
Resolved
Jun 03 at 09:04am MDT
We’re pleased to inform you that the updated version of the Remote Payroll application is now live and available for download on the Google Play Store.
We recently identified the root cause of the issue affecting time recording and sync actions on Android (Droid) devices. Our team has developed a fix, which has been fully tested and released.
To ensure a smooth transition and proper functionality, please follow the steps below to complete the update:
Uninstall the current version of the Remote Payroll app from your device.
Restart your device to help clear any residual cache.
Download and install the updated version from the Google Play Store.
We sincerely apologize for any inconvenience caused and appreciate your continued patience and support. If you experience any further issues, please contact our support team.
Thank you,
Anthony Tari
Vice President of Operations
Affected services
Mobile Applications
Updated
Jun 02 at 03:59pm MDT
We have identified the root cause of the issue affecting time recording and sync actions within the Remote Payroll application on Droid devices. A fix has been developed and tested by our QA team, and a new version of the application is being pushed to the Google Play Store.
Please note that it may take up to 24–48 hours for Google to approve and make the updated application available for download. Once the new version is live, we kindly ask that users follow these steps:
Uninstall the current version of the Remote Payroll app.
Restart your device to help clear the cache.
Download and install the updated version from the Google Play Store.
We sincerely apologize for the inconvenience and thank you for your continued patience and understanding. We will provide a notification once the new application is confirmed available on the Google Play Store.
Affected services
Mobile Applications
Updated
Jun 02 at 12:04pm MDT
We have identified the root cause of the issue affecting time recording and sync actions within the Remote Payroll application on Droid devices. A fix has been developed and is currently undergoing testing by our QA Team to ensure it fully resolves the problem.
We appreciate your continued patience and understanding as we work to restore full functionality. Further updates will be provided as they become available.
Affected services
Mobile Applications
Created
Jun 02 at 09:19am MDT
We are currently receiving reports that some users are experiencing issues with recording time and performing sync actions within the Remote Payroll application on Droid devices.
Our team is actively investigating the root cause. We will continue to provide updates on this page as more information becomes available.
Thank you for your patience and understanding.
Affected services
Mobile Applications