Back to overview
Degraded

Issue Identified - Time Tracking

Jun 3, 2026 at 2:26am UTC
Affected services
Platform Solutions

Resolved
Jun 5, 2026 at 2:48pm UTC

The hotfix addressing the issues related to Time Tracking has been successfully deployed during our scheduled maintenance window.

This issue is now fully resolved.

We apologize for the inconvenience this may have caused and thank you for your patience and continued partnership.

Updated
Jun 5, 2026 at 12:51am UTC

We have an update on the two issues impacting our Time Tracking module. Our Product and Development teams have identified the root cause and developed a fix for both issues. This fix will be deployed into production tonight.
The first issue was a permissions error that appeared when attempting to edit or create user and employee records. The second issue involved entering negative units on a timesheet.
Once the deployment is complete, both issues will be resolved and the temporary workarounds will no longer be necessary. We will confirm here once the fix is live.
We sincerely apologize for the inconvenience this has caused and thank you for your patience as we worked to resolve this as quickly as possible.

Created
Jun 3, 2026 at 2:26am UTC

We are currently aware of two issues impacting our Time Tracking module. Our Product and Development teams have identified the root cause and are actively working on a resolution. We will continue to provide updates here as more information becomes available.

The first issue is a permissions error that appears when attempting to edit or create user and employee records. In the meantime, please reach out to Support and we will make these changes for you.

The second issue involves entering negative units on a timesheet. A temporary workaround is available that will allow you to enter these units until the permanent fix is deployed.

From the timesheet, double-click in the box where you want to code the hours. A window labeled "Add Time Record" will appear. Under the "Units" section, you can enter the negative hours, and once you click "Save Time," the change will be reflected on your timesheet.

We apologize for the inconvenience this may cause and appreciate your patience as we work to resolve this issue as quickly as possible. Additional updates will be provided as more information becomes available.