Back to overview
Degraded

Status Update – Time Entry Issue for Certain User Roles

Jun 23 at 04:16pm MDT
Affected services
Mobile Applications

Resolved
Jun 25 at 09:38am MDT

We’re pleased to share that the updated Remote Payroll app for Android is now being deployed to the Google Play Store. This update includes a fix for the issue that prevented some Android users from selecting a payroll group or running a sync in the mobile app.

Reminder for iOS Users:
If you're encountering issues recording time, please check your role settings. As of June 19, users with Payroll Admin or Payroll Manager access can no longer record time via the mobile app. This change was made to help prevent time entry-related errors.

If you are a Payroll Admin or Payroll Manager, please use the Web application to record time.

If this access was applied in error and is later removed, you will regain time entry functionality in the mobile app.

Thank you for your patience and for being a valued client.

Updated
Jun 24 at 02:59pm MDT

We’ve completed a fix for the issue affecting Android (Droid) users who were unable to select a payroll group or run a sync in the mobile app. The update is currently undergoing final review by our QA team. Once approved, it will be submitted to the Google Play Store for review and publishing.

As a reminder for iOS users: If you're experiencing issues recording time, please verify your role settings. Users with Payroll Admin or Payroll Manager access are restricted from recording time in the mobile app, as part of a change implemented on June 19 to prevent time entry-related errors.

If you are a Payroll Admin or Payroll Manager, please use the Web application to record time.
If this access was applied in error and is removed, you’ll be able to use the mobile app as normal.

We appreciate your patience and will provide an update once the Android fix is live in the Google Play Store.

Updated
Jun 24 at 11:53am MDT

We've isolated the issue to Android (Droid) users, who are currently unable to select a payroll group or run a sync in the mobile app. Our Product and Development teams are actively working on a fix.

For iOS users: If you're experiencing issues recording time, please check your role settings. Having Payroll Admin or Payroll Manager access will prevent time entry in the mobile app, due to a change implemented in our June 19 release to reduce time entry-related errors.

If you are a Payroll Admin or Payroll Manager, please use the Web application to record time.
If this access was applied in error and is removed, you will regain the ability to use the mobile app as normal.

We appreciate your patience and will provide further updates as they become available.

Created
Jun 23 at 04:16pm MDT

We are currently investigating reports that some users with the roles of Superintendent or Project Manager are unable to record their time in the application.

Our product and development teams are actively working to identify and resolve the issue.

As part of our recent release on Thursday night, June 19, a change was implemented to prevent Payroll Admins and Payroll Managers from recording time in the mobile app to avoid time entry-related errors.

If you are a Payroll Admin or Payroll Manager and encounter an error message when attempting to record time, please use the Web application to continue time entry.

We appreciate your patience and will share further updates as they become available.